Usage auto-reload issue

Incident Report for Amp

Resolved

The issue has been fixed and we've reached out to affected users.
Posted Sep 17, 2025 - 22:42 UTC

Investigating

We're currently investigating an issue with usage auto-reloads, and we will reach out to affected users.
Posted Sep 17, 2025 - 19:53 UTC
This incident affected: Payment Processing.